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TSDS PEIMS Fall Submission Data for
Business

Created: 10/1/2024
Reviewed: 10/21/2024
Revised: 10/21/2024

This document outlines key Business data that is submitted during the Public Education Information
Management System (PEIMS) Fall Submission and used by the Texas Education Agency (TEA). As
the year progresses, this document may be updated to include additional fields of data.

For a complete list of submission rules and edits, see
https://tealprod.tea.state.tx.us/TWEDSAPI/23/398/403/DataComponents/Entity/List

This document assumes you are familiar with the basic features of the ASCENDER Business system
and have reviewed the ASCENDER Business Overview guide.

Some of the images and/or examples provided in this document are for informational
purposes only and may not completely represent your LEA’s process.

Prerequisites

Review the following and take action as needed:

❏ Ensure applicable employees have the correct roles and permissions in ASCENDER Security
Administration to access pages needed for TSDS reporting.

❏ Create responsibility records in Personnel for staff whose Staff Service begins with “S.” Review
the Responsibilities - Quick Reference Chart.

* The underlined text indicates the domain's submission level as it appears on the District
Administration > Options > TSDS > Domains & Entities page.

https://tealprod.tea.state.tx.us/TWEDSAPI/23/398/403/DataComponents/Entity/List
https://help.ascendertx.com/districtadmin/doku.php/academy/business_overview_guide
https://help.ascendertx.com/business/doku.php/academy/responsibilitychart
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I. Education Organization Domain
First Level Submission

The Education Organization domain includes information about public, charter, education service
center, organization, or agency.

Information from AskTED is imported into the Operational Data Store (ODS). As you send data,
TEA matches the School ID (county district number) to existing district and campus information
to ensure that the reported data is credited to the correct Local Education Agency (LEA).

Verify district information for current/prior school year.1.

Verify district information for current/prior school year

District Administration > Tables > District Information > District Name/Address

❏ In the Year field, type the four-digit school year for which you want to add or retrieve data
and click Retrieve.

❏ Verify the ESC Region Number and ESC County District Number are accurate. The ESC
County District Number is the six-digit ESC county district number assigned by Texas
Education Agency (TEA).

ESC County District Numbers

❏ Click Save for each year; each year is a separate record.

Verify campus information/exclude non-instructional campuses from reporting.2.

https://help.ascendertx.com/districtadmin/doku.php/tables/districtinformation/districtnameaddress
https://help.ascendertx.com/districtadmin/lib/exe/detail.php/general/ed_org_district_info.png?id=academy%3Afallbusinesspeims
https://help.ascendertx.com/districtadmin/doku.php/general/esc_county_district_numbers
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Verify campus information/exclude non-instructional campuses from
reporting

District Administration > Tables > District Information > Campus Name/Address

Ensure the Exclude from reporting to TEA checkbox is selected for all non-instructional
campuses/departments to exclude them from being reported to TEA.

❏ In the Year field, type the four-digit school year for which you want to add or retrieve data
and click Retrieve.

❏ Retrieve each campus record and confirm that the address and phone numbers are accurate.

❏ Review the following guidelines as consideration for selecting the Exclude from reporting
to TEA checkbox:

Instructional campuses listed in ASKTed (001, 041, 101, etc.) should not have the
Exclude from reporting to TEA checkbox selected.
Non-instructional campuses (701, 750, 999, and other campuses or departments needed
for purchasing) should have Exclude from reporting to TEA selected.
Education Service Centers (ESCs): Exclude all campuses from TEA reporting.
Business-only LEAs: Exclude all campuses from TEA reporting.

❏ Click Save for each campus; each campus is a separate record.

Verify Shared Services Arrangements, as needed.3.

Verify Shared Services Arrangements, as needed

District Administration > Tables > District Information > Shared Services Arrangement

https://help.ascendertx.com/districtadmin/doku.php/tables/districtinformation/campusnameaddress
https://help.ascendertx.com/districtadmin/lib/exe/detail.php/general/ed_org_campus_info.png?id=academy%3Afallbusinesspeims
https://help.ascendertx.com/districtadmin/doku.php/tables/districtinformation/sharedservicesarrangement
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❏ In the Year field, type the four-digit reporting year for which you want to add or retrieve data
and click Retrieve. For example, the reporting year for the 2024-2025 school year is 2025.

❏ Under Shared Services Arrangements (left side of page), enter all Shared Services
Arrangements for which the LEA is a member.

Indicate the Shared Services Type and Fiscal Agent District ID.
If the LEA is the Fiscal Agent of the SSA, click the spyglass for that SSA record.

❏ Under Shared Services Arrangement Member Amounts (right side of page), click +Add
to add a row. Complete the following fields:

Member District ID (CCCDDD)
Fund
Fiscal Year - This is the last fiscal year's SSA data. For example, for reporting year 2025
(school year 2024-2025), use SSA data from the 2023-2024 financial fiscal year 4.
Amount- This is the amount spent on the member’s behalf.

Note: Since each year is entered on this tab, there are not separate tabs for the current
and prior years as in previous years.

❏ Click Save.

II. Staff Domain
Second Level Submission

The Staff Domain includes general staff information for a local education agency (LEA).

https://help.ascendertx.com/districtadmin/lib/exe/detail.php/general/ed_org_ssa.png?id=academy%3Afallbusinesspeims
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This section provides you with a clear view of all the Business fields included in the Staff Domain for
Fall PEIMS reporting. The information is organized by where it exists in the system (application, menu,
page, and tab). This will help you easily locate and correct data as needed. You can also generate
user-created reports to assist you in verifying data.

Personnel1.

Personnel

Personnel > Maintenance > Staff Demo > Demographic Information

Staff ID/SSN
Texas Unique Staff ID
First, Middle, and Last Name
Sex
DOB
Ethnicity
Race

https://help.ascendertx.com/business/doku.php/personnel/maintenance/staffdemo/demographicinformation
https://help.ascendertx.com/districtadmin/lib/exe/detail.php/general/staff_domain_staff_demo.png?id=academy%3Afallbusinesspeims
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Personnel > Maintenance > Staff Demo > Responsibility

Note: The School Year will default to the School Year for PEIMS on the District HR
Options page.

Campus
Co-op/SSA LEA - Co-op staff should be reported by the fiscal agent. Type the nine-digit
ID (six-digit district ID + three-digit campus ID) to identify the LEA (district and campus)
where the SSA/Co-op employees has work assignment records if other than their home
district/campus. If this field is populated, then the Campus field should be blank and vice
versa.
Staff Classification - This field is previously known as Role ID.
ESC/SSA
Staff Service
SPED Student Age Range
Pop Served
Monthly Minutes
# of Students (in class), if applicable
Begin Date
End Date

https://help.ascendertx.com/business/doku.php/personnel/maintenance/staffdemo/responsibility
https://help.ascendertx.com/districtadmin/lib/exe/detail.php/general/staff_domain_responsibility.png?id=academy%3Afallbusinesspeims
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Personnel > Maintenance > Employment Info

Original Emp Date
Latest Re-Employ Date (if applicable)
Termination Date
Percent Day Employed
Highest Degree
Total Years Professional Experience
Total Years Experience In District (professional staff only)
Auxiliary Role ID, Begin Date and End Date, if applicable (TSDS = Staff Classification)
Paraprofessional Certification, Begin Date and End Date, if applicable

Payroll2.

Payroll

Payroll > Maintenance > Staff Job/Pay Data > Job Info

https://help.ascendertx.com/business/doku.php/personnel/maintenance/employmentinfo
https://help.ascendertx.com/districtadmin/lib/exe/detail.php/general/staff_domain_employment_info.png?id=academy%3Afallbusinesspeims
https://help.ascendertx.com/business/doku.php/payroll/maintenance/staffjobpaydata/jobinfo
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Total - Note: For Pay Type 3 (hourly employees), enter an estimate of the annual salary.
Begin Date and End Date
# of Days Empld
(If applicable) Exclude Days for TEA - If an employee has multiple jobs listed on this
page, the system automatically calculates the total number of days worked across all
jobs. For example, if a teacher works 187 days and has a secondary job as a bus driver for
180 days, by default, the system adds all days for a total of 367 days. This does not
accurately reflect the actual number of days worked since the employee does not actually
work 367 days. To ensure accurate reporting, it is recommended to only report the job
with the highest number of days. For jobs with fewer days, select Exclude Days for TEA
to prevent those days from being included in the total.

Position Management3.

Position Management

Position Management > Maintenance > PMIS Position Admin

Ensure the Exclude Days for TEA checkbox is selected for all secondary jobs.

https://help.ascendertx.com/districtadmin/lib/exe/detail.php/general/staff_domain_job_info.png?id=academy%3Afallbusinesspeims
https://help.ascendertx.com/business/doku.php/positionmanagement/maintenance/pmispositionadmin/positionrecord
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The Exclude Days for TEA checkbox can be found on the following Position Management >
Maintenance pages:

PMIS Position Admin > Position Record
PMIS Position Modify > Position Record
PMIS Positions History > History
PMIS Change in Position > Change in Compensation

District Administration4.

District Administration

District Administration > Tables > District Information > District Name/Address

Add data for contracted instructional staff as needed.

https://help.ascendertx.com/districtadmin/lib/exe/detail.php/general/staff_domain_pmis.png?id=academy%3Afallbusinesspeims
https://help.ascendertx.com/districtadmin/doku.php/tables/districtinformation/districtnameaddress


District Administration

2025/01/18 12:56 10 TSDS PEIMS Fall Submission Data for Business

❏ In the Year field, type the four-digit school year for which you want to add or retrieve data
and click Retrieve.

❏ Under Contracted Instructional Staff, add records and complete the following fields:

Campus
Program Intent Code
Number of FTEs

District Administration > Maintenance > Non-Employee

For contracted instructional staff, complete all fields under Instructional Staff.

https://help.ascendertx.com/districtadmin/lib/exe/detail.php/general/staff_domain_district_info.png?id=academy%3Afallbusinesspeims
https://help.ascendertx.com/districtadmin/doku.php/maintenance/nonemployee
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❏ Be sure to select a TSDS Staff Type code for all non-employee staff members with a 2023
start date or later.

• Select 3 - Contracted Professional Staff if the staff member is a Contracted Professional
(instructional and non-instructional).

• Select 4 - In-District Charter Prtnr Campus Teacher if the staff member is a teacher employed
at an In-district Charter Partner Campus.

III. Finance Domain
Third Level Submission

The Finance domain includes financial information captured in accounts (both actuals and
budgeted).

https://help.ascendertx.com/districtadmin/lib/exe/detail.php/general/staff_domain_non_employee.png?id=academy%3Afallbusinesspeims
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Add crosswalks.1.

Add crosswalks

Finance > Tables > TSDS Crosswalks

Map financial data from the LEA's set of accounts to TEA's Chart of Accounts for both the
current and previous file IDs.

Verify the TSDS crosswalks copied from State Reporting are correct. Make corrections as
needed.

Verify that there is not a crosswalk for the automatic crosswalks processed by ASCENDER.
Automatic crosswalks are applied after any applicable crosswalks entered on this page. Review
the Automatic Crosswalks section on the Finance TSDS Crosswalk Tables page.

As an example, a one-campus LEA that budgets and books expenditure records to campuses
101 and 001 should establish a crosswalk to move expenditures from Organization code 101 to
Organization code 001.

https://help.ascendertx.com/business/doku.php/finance/tables/tsdscrosswalks
https://help.ascendertx.com/business/doku.php/general/finance_tsdscrosswalk_tables
https://help.ascendertx.com/districtadmin/lib/exe/detail.php/general/finance_domain_crosswalks.png?id=academy%3Afallbusinesspeims


District Administration

2025/01/18 12:56 13 TSDS PEIMS Fall Submission Data for Business

Verify Budget data.2.

Verify Budget data

Budget data is extracted from Finance for applicable funds. The totals include entries made into
the system until the end of October or accounting period 10. It is recommended that all budget
amendments be entered by the PEIMS Fall Snapshot date, which is the last Friday in October.

The following data is reported:

Fund (199, 240, and 599)
Function
Object

Report 5XXX-8XXX
61XX are collapsed into 6100, 62XX into 6200, 63XX into 6300, etc.

https://help.ascendertx.com/districtadmin/lib/exe/detail.php/general/finance_domain_crosswalk_example.png?id=academy%3Afallbusinesspeims
https://help.ascendertx.com/districtadmin/lib/exe/detail.php/general/finance_domain_general_ledger.png?id=academy%3Afallbusinesspeims
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Organization
Fiscal Year
Program Intent
Amount
Begin & End Date (time/date stamp assigned at the time of data entry; not the
transaction date)

Verify Payroll data.3.

Verify Payroll data

Payroll > Maintenance > Staff Job/Pay Data > Distributions

Verify all account codes, amounts, and activity codes. All employees should have at least one
row with Activity Code 78 (non-salary) or 80 (Base Salary).

IV. TSDS Level 1 Errors

This page is used to view and print a listing of Level 1 errors that occurred in various
domains/entities when the API interface files begin processing into the TEA database. ASCENDER
does not control the content of these errors.

All TSDS Level 1 Error reports are displayed and printed in landscape orientation by default.

Review/correct TSDS Level 1 Errors.1.

https://help.ascendertx.com/business/doku.php/payroll/maintenance/staffjobpaydata/distributions
https://help.ascendertx.com/districtadmin/lib/exe/detail.php/general/finance_domain_distributions_tab.png?id=academy%3Afallbusinesspeims


District Administration

2025/01/18 12:56 15 TSDS PEIMS Fall Submission Data for Business

Review/correct TSDS Level 1 Errors

District Administration > Inquiry > TSDS Level 1 Errors

Review TSDS Level 1 errors on a regular basis and correct data as needed. If not addressed,
these errors will prevent data from flowing to the Operational Data Store (ODS).

You can print various reports using the following options:

Select the checkbox next to the domains (rows) to be included in the report and click
Print. This prints errors associated with the selected Domain > Entity.
Click Extract Errors Reprint to display the processes that completed successfully in the
last extract as well as a list of errors that need to be corrected. This should be the focus
for most error resolution.
Click Extract Prior Year Reprint to display data that was extracted for Mid-Year PEIMS.
Click Extract Budget Reprint to display Budget data most recently extracted for Fall
PEIMS.
The Extract Payroll Reprint button displays Payroll data most recently extracted for Fall
PEIMS.

Note: If included in the report, the Action Type column displays the expected action of
the record that was sent to the Operational Data Store (ODS):

I - Insert
U - Update
D - Delete

https://help.ascendertx.com/districtadmin/doku.php/inquiry/tsdslevel1errors
https://help.ascendertx.com/districtadmin/lib/exe/detail.php/general/fall_business_level_1_errors.png?id=academy%3Afallbusinesspeims
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V. Data Quality Tips
✔ Step Completion

Date
Completed
By

Notes

Verify the following for Active Employees:
Personnel > Maintenance > Employment Info
Verify that active employees only have one employment type
selected, Employment Type or Retiree Employment
Type.
Verify all employees with a Latest Re-employment Date
do not have a Termination Date. For re-hires, delete the
Termination Date and Reason.
Verify all employees have a Percent of Day Employed.
Verify all auxiliary staff have an Auxiliary Role ID with a
Begin Date .
Verify all paraprofessional staff with a Paraprofessional
Certification have Para Cert selected with a Begin Date.
Verify that employees with an Employment Status of 09
Other are not reported to PEIMS. If the employee should be
reported to PEIMS, it is recommended that you change the
Employment Status to 02 Active auxiliary personnel

Be sure to add an Auxiliary Role ID to these employees. It is
recommended that you use 222 Other Non-Exempt Auxiliary.
Verify the following for Terminated Employees:
Personnel > Maintenance > Employment Info
Verify the employee record has a Termination Date and
Termination Reason.
Verify the employee record has an End Date for the
Auxiliary Role ID and/or Paraprofessional Certification.
Verify the employee record has an updated Employment
Status, if not, select the appropriate code.
Personnel > Maintenance > Staff Demo > Responsibility
Verify the employee record has an End Date on the
Responsibility record if one exists.
Payroll > Maintenance > Staff Job/Pay Data > Pay Info
Verify the employee record has a Pay Status of Inactive.
Verify the following for Finance and Budget Data:
Finance > Maintenance > Create Chart of Accounts
Verify that a “parent” account is not being used in the
account code structure to enter data. (Examples: Fund code
100, 200; Object code 1100, 5700, 6300)

https://help.ascendertx.com/business/doku.php/personnel/maintenance/employmentinfo
https://help.ascendertx.com/business/doku.php/personnel/maintenance/employmentinfo
https://help.ascendertx.com/business/doku.php/personnel/maintenance/staffdemo/responsibility
https://help.ascendertx.com/business/doku.php/payroll/maintenance/staffjobpaydata/payinfo
https://help.ascendertx.com/business/doku.php/finance/maintenance/createchartofaccounts
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✔ Step Completion
Date

Completed
By

Notes

Verify the correct organization codes are being used.

• If the organization code is 701-750, then function code
should be 41, 53 or 99. Function 41 should not have a
organization code of 999. The organization codes are
typically 701-703, 720, 750 or 751. (ESCs are the exception.)
Reference the FAR Guide and make any changes for accounts
that are not crosswalked.

• Expenditure accounts (6XXX) should not have an
organization code of 000 or PIC of 00.
Verify the correct Program Intent Codes (PIC) are being used.

• Funds 205, 255, 270, and 429 should not have PIC 30.
These funds are typically PIC 24.

• Verify you do not have PICs 31, 32, 34, or 35 in your chart
of accounts. If you do, you will need to mass crosswalk the
data to another account code. These codes have been retired
and deleted from the FAR Guide.
Finance > Inquiry > General Ledger Inquiry
Verify expenditures exist for object code 6491 to record
Statutorily Required Public Notices.
Verify at least one account code exists for instructional staff
development (function 13) with budget amounts (for Fall
PEIMS) and actual expenditures (for Mid-Year PEIMS) greater
than zero.
Verify at least one account code exists for instructional
resources and media services (function 12 and object
6100-6600) with a budget and actual expenditures greater
than zero.
Verify at least one account code exists for guidance,
counseling, evaluation services or social work services or
health services in function 31-33, object 6100-6600 with
amounts greater than zero.
Verify at least one account code exists with object code 6212
for audit services.
Verify one account code exists for Matching State Funds
(object 5829) in funds 240 and 410.

The District PEIMS Coordinator is responsible for setting up the following, unless other
arrangements have been established.

Do not make changes to this information unless authorized.

✔ Step Completion
Date

Completed By Notes

https://help.ascendertx.com/business/doku.php/finance/inquiry/generalledgerinquiry/generalledgerinquiry
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✔ Step Completion
Date

Completed By Notes

District Administration > Options > TSDS > Options
Verify that the As-of-Date and School Start Window
(SSW) Date fields have the correct dates.
Ensure that email address(es) are entered under Finance
Extract Distribution List and Personnel/Payroll
Extract Distribution List. These designated email
addresses allow a person or group of persons to receive
extract emails.
District Administration > Options > TSDS > Connection
Verify the API URL, Key, and Secret are accurate.
District Administration > Options > TSDS > Domains & Entities
Make selections on Domains & Entities as described in
the ASCENDER TSDS New School Year Best Practice
Guide.

https://help.ascendertx.com/districtadmin/doku.php/options/tsds/options
https://help.ascendertx.com/districtadmin/doku.php/options/tsds/connection
https://help.ascendertx.com/districtadmin/doku.php/options/tsds/domainsandentities
https://help.ascendertx.com/districtadmin/doku.php/academy/district_admin_newsy_best_practice_gde
https://help.ascendertx.com/districtadmin/doku.php/academy/district_admin_newsy_best_practice_gde

	Table of Contents
	TSDS PEIMS Fall Submission Data for Business
	Prerequisites
	I. Education Organization Domain
	Verify district information for current/prior school year
	Verify campus information/exclude non-instructional campuses from reporting
	Verify Shared Services Arrangements, as needed

	II. Staff Domain
	Personnel
	Payroll
	Position Management
	District Administration

	III. Finance Domain
	Add crosswalks
	Verify Budget data
	Verify Payroll data

	IV. TSDS Level 1 Errors
	Review/correct TSDS Level 1 Errors

	V. Data Quality Tips


