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Fall PEIMS for Business - Quick Checklist

Updating TSDS - Quick Checklist
✔ Step Completion Date Completed By Notes

Security Administration > Manage Users & Roles
Ensure applicable employees have appropriate security
permissions set up on their user profiles to access pages
needed for TSDS reporting.
<color #ed1c24>Education Organization Domain</color>
District Administration > Tables > District Information > District Name/Address
Verify the ESC Region Number and ESC County
District Number are accurate. The ESC County
District Number is the six-digit ESC county district
number assigned by Texas Education Agency (TEA).

ESC County District Numbers
District Administration > Tables > District Information > Campus Name/Address
Ensure the Exclude from reporting to TEA checkbox
is selected for all non-instructional
campuses/departments.

• Instructional campuses listed in ASKTed (001, 041,
101, etc.) should not have the Exclude from
reporting to TEA checkbox selected.

• Non-instructional campuses (701, 750, 999, and other
campuses or departments needed for purchasing)
should have Exclude from reporting to TEA selected.

• Education Service Centers (ESCs): Exclude all
campuses from TEA reporting.

• Business-only LEAs: Exclude all campuses from TEA
reporting.
District Administration > Tables > District Information >
Shared Services Arrangement

Verify Shared Services Arrangements, as needed.
<color #ed1c24>Staff Domain</color>
Personnel > Maintenance > Demographic Information, Responsibility, and Employment Info
Add/update employee Personnel records.

Note: Fiscal agents should use the Co-op/SSA LEA field on the
Responsibility tab to report Co-op staff.
Payroll > Maintenance > Staff Job/Pay Data > Job Info
Ensure the Exclude Days for TEA checkbox is selected
for all secondary jobs.
Position Management > Maintenance > PMIS Position Admin > Position Record

https://help.ascendertx.com/securityadmin/doku.php/manageusers/manageusers
https://help.ascendertx.com/securityadmin/doku.php/manageroles/manageroles
https://help.ascendertx.com/districtadmin/doku.php/tables/districtinformation/districtnameaddress
https://help.ascendertx.com/districtadmin/doku.php/general/esc_county_district_numbers
https://help.ascendertx.com/districtadmin/doku.php/tables/districtinformation/campusnameaddress
https://help.ascendertx.com/districtadmin/doku.php/tables/districtinformation/sharedservicesarrangement
https://help.ascendertx.com/districtadmin/doku.php/tables/districtinformation/sharedservicesarrangement
https://help.ascendertx.com/business/doku.php/personnel/maintenance/staffdemo/demographicinformation
https://help.ascendertx.com/business/doku.php/personnel/maintenance/staffdemo/responsibility
https://help.ascendertx.com/business/doku.php/personnel/maintenance/employmentinfo
https://help.ascendertx.com/business/doku.php/payroll/maintenance/staffjobpaydata/jobinfo
https://help.ascendertx.com/test/business/doku.php/positionmanagement/maintenance/pmispositionadmin/positionrecord
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Updating TSDS - Quick Checklist
✔ Step Completion Date Completed By Notes

Ensure the Exclude Days for TEA checkbox is selected
for all secondary jobs. The Exclude Days for TEA
checkbox can be found on the following Position
Management > Maintenance pages:

• PMIS Position Admin > Position Record

• PMIS Position Modify > Position Record

• PMIS Positions History > History

• PMIS Change in Position > Change in Compensation
District Administration > Maintenance > Non-Employee
For contracted instructional staff, complete all fields
under Instructional Staff.

Be sure to select a TSDS Staff Type code for all non-
employee staff members with a 2023 start date or later.

• Select 3 - Contracted Professional Staff if the staff
member is a Contracted Professional (instructional and
non-instructional).

• Select 4 - In-District Charter Prtnr Campus Teacher if
the staff member is a teacher employed at an In-district
Charter Partner Campus.
District Administration > Tables > District Information > District Name/Address
Add data for contracted instructional staff as needed.
<color #ed1c24>Finance Domain</color>
Finance > Tables > TSDS Crosswalks
Map financial data from the LEA's set of accounts to
TEA's Chart of Accounts for both the current and
previous file IDs.

Verify the TSDS crosswalks copied from State Reporting
are correct. Make corrections as needed.

Verify that there is not a crosswalk for the automatic
crosswalks processed by ASCENDER. Automatic
crosswalks are applied after any applicable crosswalks
entered on this page. Review the Automatic
Crosswalks section on the Finance TSDS Crosswalk
Tables page.
Finance > Inquiry > General Ledger Inquiry > General Ledger Account Summary
Verify budget data.
TSDS Level 1 Errors
District Administration > Inquiry > TSDS Level 1 Errors
Review the Extract Errors reports and the TSDS Level
1 Errors report. (This is an ongoing activity.)

https://help.ascendertx.com/districtadmin/doku.php/maintenance/nonemployee
https://help.ascendertx.com/districtadmin/doku.php/tables/districtinformation/districtnameaddress
https://help.ascendertx.com/business/doku.php/finance/tables/tsdscrosswalks
https://help.ascendertx.com/business/doku.php/general/finance_tsdscrosswalk_tables
https://help.ascendertx.com/business/doku.php/general/finance_tsdscrosswalk_tables
https://help.ascendertx.com/business/doku.php/finance/inquiry/generalledgerinquiry/generalledgeraccountsummary
https://help.ascendertx.com/districtadmin/doku.php/inquiry/tsdslevel1errors
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Data Quality Tips

TSDS Data Quality Checklist

Budget Data

ASCENDER
Breadcrumb

Step

Finance >
Inquiry >
General Ledger
Inquiry

Click  to display all funds. Verify all funds are valid for the 2026 Budget. If not,
create TSDS Crosswalks (Fund to Fund).

BudgetFund - Table ID C145B
Click  to display all functions. Verify all functions are valid for the 2026 Budget. If
not, create TSDS Crosswalks (Function to Function).

TIP: Expense function codes should not be 00.

BudgetFunction - Table ID C146B
Click  to display all objects. Verify all objects are valid for the 2026 Budget. If not,
create TSDS Crosswalks (Object to Object).

TIP: Expense object codes should not end with 0.

BudgetObject - Table ID C159B
Click  to display all Program Intent Codes (PICs). Verify all PICs are valid for the
2026 Budget. If not, create TSDS Crosswalks (Program Intent to Program Intent).

TIP: Expense program intent code should not be 00.

BudgetProgramIntent - Table ID C147B
Click  to display all organization codes. Verify all organization codes are valid for
the 2026 Budget. If not, create TSDS Crosswalks (Org to Org).
Verify organizations 001-698 are tied to a campus ID in AskTED. If not, create TSDS
crosswalks as needed (Org to Org).
Click  to verify accounts with PIC 91 are using function codes 36, 51 or 52.
Click  to verify combinations:

• Org 701-750 should only be used in functions 41, 53, 99
• Function 71 should be used with object 65XX
• Funds 205, 255, 270, 429 should be used with PIC 24 rather than 30
• Expense objects (6XXX) should not be used with Org 000, 709-719, 726-749 or
800-997
• Expense Objects (6XXX) should not be used with PIC 00
• Expense Objects (6XXX should not use function 00)

Account Code Matrices in FAR
Click  to verify the fiscal year for PEIMS Budget Funds. The fiscal year is 6 for the
2025-2026 fiscal year. (Only applies to funds reported for Fall PEIMS: 199, 240, 420,
599)

https://help.ascendertx.com/business/doku.php/finance/inquiry/generalledgerinquiry/generalledgerinquiry
https://help.ascendertx.com/business/doku.php/finance/inquiry/generalledgerinquiry/generalledgerinquiry
https://help.ascendertx.com/business/doku.php/finance/inquiry/generalledgerinquiry/generalledgerinquiry
https://help.ascendertx.com/business/doku.php/finance/inquiry/generalledgerinquiry/generalledgerinquiry
https://help.ascendertx.com/districtadmin/lib/exe/detail.php/images/smallpicklist.gif?id=academy%3Aupdate_buisness_tsds_checklist
https://help.ascendertx.com/districtadmin/lib/exe/detail.php/images/smallpicklist.gif?id=academy%3Aupdate_buisness_tsds_checklist
https://help.ascendertx.com/districtadmin/lib/exe/detail.php/images/smallpicklist.gif?id=academy%3Aupdate_buisness_tsds_checklist
https://help.ascendertx.com/districtadmin/lib/exe/detail.php/images/smallpicklist.gif?id=academy%3Aupdate_buisness_tsds_checklist
https://help.ascendertx.com/districtadmin/lib/exe/detail.php/images/smallpicklist.gif?id=academy%3Aupdate_buisness_tsds_checklist
https://help.ascendertx.com/districtadmin/lib/exe/detail.php/images/smallpicklist.gif?id=academy%3Aupdate_buisness_tsds_checklist
https://help.ascendertx.com/districtadmin/lib/exe/detail.php/images/smallpicklist.gif?id=academy%3Aupdate_buisness_tsds_checklist
https://tea.texas.gov/finance-and-grants/financial-accountability/fasrg/fasrg19-module1-far-appendices.pdf
https://help.ascendertx.com/districtadmin/lib/exe/detail.php/images/smallpicklist.gif?id=academy%3Aupdate_buisness_tsds_checklist
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ASCENDER
Breadcrumb

Step

Verify expenditures exist for object code 6491 to record Statutorily Required Public
Notices.
Verify at least one account code exists for instructional staff development (function
13) with budget amounts.
Verify at least one account code exists for general administration (function 41) with
budget amounts greater than zero.
Verify at least one account code exists for instructional resources and media
services (function 12 and object 6100-6600) with a budget and actual expenditures
greater than zero.
Verify at least one account code exists for guidance, counseling, evaluation services
or social work services or health services in function 31-33, object 6100-6600 with
amounts greater than zero.
Verify at least one account code exists with object code 6212 for audit services.
Verify one account code exists for Matching State Funds (object 5829) in funds 240
and 410.
Verify budgets in object 65XX are tied to function 71.

Staff Data

Active Employees:

ASCENDER
Breadcrumb

Step

Personnel >
Maintenance >
Staff Demo >
Demographic
Information

Verify the following fields are completed for all regular employees, contracted
instructional staff, and long-term substitutes:

• Texas Unique Staff ID
• DOB
• Sex
• Race
• Ethnicity

Generate a user-created report to verify accuracy.

Staff Entity
Personnel >
Maintenance >
Staff Demo >
Credentials

Ensure the PK Teacher Specialization is added to all PK Teachers of Record.

PK Teacher Requirement - Table ID C207

Ensure all TIA teachers have TIA data added. If TIA eligible, generate a user-
created report to ensure they also have Creditable Years of Service. This is
reported in Class Roster.

TIA Designation - Table ID C322

Personnel >
Maintenance >
Staff Demo >
Responsibility

Ensure Responsibility records are complete and accurate for applicable staff.

StaffEducationOrganizationAssignmentAssociation Entity

Responsibilities - Quick Reference Chart

https://help.ascendertx.com/business/doku.php/personnel/maintenance/staffdemo/demographicinformation
https://help.ascendertx.com/business/doku.php/personnel/maintenance/staffdemo/demographicinformation
https://help.ascendertx.com/business/doku.php/personnel/maintenance/staffdemo/demographicinformation
https://help.ascendertx.com/business/doku.php/personnel/maintenance/staffdemo/demographicinformation
https://help.ascendertx.com/business/doku.php/personnel/maintenance/staffdemo/demographicinformation
https://help.ascendertx.com/business/doku.php/personnel/maintenance/staffdemo/credentials
https://help.ascendertx.com/business/doku.php/personnel/maintenance/staffdemo/credentials
https://help.ascendertx.com/business/doku.php/personnel/maintenance/staffdemo/credentials
https://help.ascendertx.com/business/doku.php/personnel/maintenance/staffdemo/credentials
https://help.ascendertx.com/business/doku.php/personnel/maintenance/staffdemo/responsibility
https://help.ascendertx.com/business/doku.php/personnel/maintenance/staffdemo/responsibility
https://help.ascendertx.com/business/doku.php/personnel/maintenance/staffdemo/responsibility
https://help.ascendertx.com/business/doku.php/personnel/maintenance/staffdemo/responsibility
https://help.ascendertx.com/business/doku.php/academy/responsibilitychart
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ASCENDER
Breadcrumb

Step

Responsibility records with a Staff Service beginning with SE must have Pop
Served set to 06.

Population Served - Table ID C030
Responsibility records for aides must have Number of Students set to 0.

Personnel >
Maintenance >
Employment Info

Verify that active employees only have one employment type selected,
Employment Type or Retiree Employment Type.

Staff Type - Table ID C181
Verify Employee Status is 1-5 or A when data is ready to be sent. (TIP: It is
recommended to set the Employee Status to 0 - Pending while gathering required
data elements.

TSDS Best Practices for New Employee Records
Verify all employees with a Latest Re-employment Date do not have a
Termination Date. For re-hires, delete the Termination Date and Reason.
Verify all regular employees have a Highest Degree.
Verify all employees have a Percent of Day Employed.
Verify professional staff have Total and In District years of experience. (exclude
current year in count)

Total Years Professional Experience
Verify all auxiliary staff have an Auxiliary Role ID with a Begin Date. Staff who
have an Auxiliary Role ID should have at least one payroll record coded to
object code 612X.

Auxiliary Role - Table ID C213
Verify all paraprofessional staff with a Paraprofessional Certification have Para
Cert selected with a Begin Date.

Paraprofessional Certification
Verify Employment Status. Only staff with an Employment Status of 01-05
and A are reported to PEIMS. When all employee data is complete and accurate,
change the Employment Status to include the record in the nightly send job.

TSDS Best Practices for New Employee Records
Personnel >
Maintenance >
TSDS Days
Employed Set

Ensure all reported staff have Number of Days Employed.

StaffEducationOrganizationEmploymentAssociation Entity

Ensure all reported staff have a Percent of Days Employed.

StaffEducationOrganizationEmploymentAssociation Entity

Terminated Employees:

ASCENDER Breadcrumb Step

Personnel > Maintenance >
Employment Info

Verify the employee record has a Termination Date and
Termination Reason.

TSDS Best Practices for Terminated Employee Records

https://help.ascendertx.com/business/doku.php/personnel/maintenance/employmentinfo
https://help.ascendertx.com/business/doku.php/personnel/maintenance/employmentinfo
https://help.ascendertx.com/business/doku.php/personnel/maintenance/employmentinfo
https://help.ascendertx.com/business/doku.php/academy/tsds_bestpractices_newemployees
https://help.ascendertx.com/business/doku.php/academy/tsds_bestpractices_newemployees
https://help.ascendertx.com/business/doku.php/personnel/maintenance/tsdsdaysemployedset
https://help.ascendertx.com/business/doku.php/personnel/maintenance/tsdsdaysemployedset
https://help.ascendertx.com/business/doku.php/personnel/maintenance/tsdsdaysemployedset
https://help.ascendertx.com/business/doku.php/personnel/maintenance/tsdsdaysemployedset
https://help.ascendertx.com/business/doku.php/personnel/maintenance/employmentinfo
https://help.ascendertx.com/business/doku.php/personnel/maintenance/employmentinfo
https://help.ascendertx.com/business/doku.php/academy/tsds_bestpractices_termemployees
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ASCENDER Breadcrumb Step
Verify the employee record has an End Date for the Auxiliary
Role ID and/or Paraprofessional Certification.
Select Extract for TSDS to include the employee in TSDS Staff
Domain extracts regardless of their employment status.
Verify the employee record has an updated Employment Status,
if not, select the appropriate code.

Personnel > Maintenance >
Staff Demo > Responsibility

Verify the employee record has an End Date on the Responsibility
record if one exists.

TSDS Best Practices for Terminated Employee Records
Payroll > Maintenance > Staff
Job/Pay Data > Pay Info Verify the employee record has an Inactive Pay Status.

Personnel > Maintenance >
TSDS Days Employed Set Verify the employee record has an End Date.

Payroll Data

ASCENDER
Breadcrumb

Step

Payroll > Reports >
User Created Report

Review employee distributions. Verify organization codes on all payroll. No
payroll expenditure codes should use org 000, 700, 709-719, 726-749, or
800-997.

Account Code Matrices in FAR
Verify admin staff coded to functions 41, 53, or 99 use valid org codes
701-750.

Account Code Matrices in FAR
Verify program intent codes on all payroll. No payroll program intent codes
should use org 00.

Account Code Matrices in FAR
Verify all staff have at least one payroll code with a Payroll Activity code of
80.
Staff paid with object 6129 must have an Auxiliary Role ID or
responsibility with Staff Classification of 033 or 036 or Classroom Position
record of 05 in the Schedule.

Personnel > Tables >
Salaries > Extra Duty

Verify Business Allowances are set to Activity Code 79.

PayrollActivity - Table ID C018

The District PEIMS Coordinator is responsible for setting up the following, unless other
arrangements have been established.

Do not make changes to this information unless authorized.

https://help.ascendertx.com/business/doku.php/personnel/maintenance/staffdemo/responsibility
https://help.ascendertx.com/business/doku.php/personnel/maintenance/staffdemo/responsibility
https://help.ascendertx.com/business/doku.php/academy/tsds_bestpractices_termemployees
https://help.ascendertx.com/business/doku.php/payroll/maintenance/staffjobpaydata/payinfo
https://help.ascendertx.com/business/doku.php/payroll/maintenance/staffjobpaydata/payinfo
https://help.ascendertx.com/business/doku.php/personnel/maintenance/tsdsdaysemployedset
https://help.ascendertx.com/business/doku.php/personnel/maintenance/tsdsdaysemployedset
https://help.ascendertx.com/business/doku.php/payroll/reports/usercreatedreports/hrreport
https://help.ascendertx.com/business/doku.php/payroll/reports/usercreatedreports/hrreport
https://tea.texas.gov/finance-and-grants/financial-accountability/fasrg/fasrg19-module1-far-appendices.pdf
https://tea.texas.gov/finance-and-grants/financial-accountability/fasrg/fasrg19-module1-far-appendices.pdf
https://tea.texas.gov/finance-and-grants/financial-accountability/fasrg/fasrg19-module1-far-appendices.pdf
https://help.ascendertx.com/business/doku.php/personnel/tables/salaries/extraduty
https://help.ascendertx.com/business/doku.php/personnel/tables/salaries/extraduty
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ASCENDER Breadcrumb Step
District Administration > Options
> TSDS > Options

Verify that the As-of-Date and School Start Window (SSW)
Date fields have the correct dates.
Ensure that email address(es) are entered under Finance Extract
Distribution List and Personnel/Payroll Extract Distribution
List. These designated email addresses allow a person or group of
persons to receive extract emails.

District Administration > Options
> TSDS > Connection Verify the API URL, Key, and Secret are accurate.

District Administration > Options
> TSDS > Domains & Entities

Make selections on Domains & Entities as described in the
ASCENDER TSDS New School Year Best Practice Guide.

https://help.ascendertx.com/districtadmin/doku.php/options/tsds/options
https://help.ascendertx.com/districtadmin/doku.php/options/tsds/options
https://help.ascendertx.com/districtadmin/doku.php/options/tsds/connection
https://help.ascendertx.com/districtadmin/doku.php/options/tsds/connection
https://help.ascendertx.com/districtadmin/doku.php/options/tsds/domainsandentities
https://help.ascendertx.com/districtadmin/doku.php/options/tsds/domainsandentities
https://help.ascendertx.com/districtadmin/doku.php/academy/district_admin_newsy_best_practice_gde
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